Uploaded image for project: 'Pentaho Reporting and Pentaho Report Designer'
  1. Pentaho Reporting and Pentaho Report Designer
  2. PRD-5601

Getting Collections in PRD and MongoDB as a datasource, with authentication, stopped working

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Severity: Urgent
    • Resolution: Fixed
    • Affects Version/s: 6.0.1 GA, 6.0.1.1 GA
    • Fix Version/s: 7.0.0 GA
    • Component/s: None
    • Labels:
    • Story Points:
      0
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.

      Description

      I built a PRPT report with MongoDB (e.g. 3.0) as a datasource. For MongoDB I use the authentication so the same in PRPT.

      When I click on "Get DBs" the databases are not populated. So, I typed the appropriate manually. Then I click on "Get Collections" - nothing gets populated. So, I typed it manually.
      The report however does not retrieve any data.

      The second part - "Get Collections" - used to work in the previous version of Pentaho.

      See the screencast presenting the way it used to work and works currently: https://pentaho.box.com/s/u3ldt804sepduzxbpzb10mcgp5fbbt4p

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              AKarneichyk Alena Karneichyk (Inactive)
              Reporter:
              dkozlowski Daniel Kozlowski (Inactive)
              Votes:
              2 Vote for this issue
              Watchers:
              10 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: