Uploaded image for project: 'Pentaho Reporting and Pentaho Report Designer'
  1. Pentaho Reporting and Pentaho Report Designer
  2. PRD-5508

Entering Cyrillic characters in the Resource Editor Window turns into ????.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Severity: High
    • Resolution: Won't Fix
    • Affects Version/s: 5.0.6 GA, 5.3.0 GA, 5.4.0 GA
    • Fix Version/s: None
    • Component/s: User Interface
    • Labels:
      None
    • Story Points:
      0
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.
    • Steps to Reproduce:
      Hide
      • Create a Simple Report.
      • When labels are directly given the value in russian then the russian char are displayed.
      • Now try to localize the report following the instructions mentioned in the below link,

      http://help.pentaho.com/Documentation/5.1/0L0/130/0C0

      • Try adding Russian characters in the Resource Editor window.
      • Click Ok.
      • Edit the properties file.
      • Russian characters are changed to ???.
      Show
      Create a Simple Report. When labels are directly given the value in russian then the russian char are displayed. Now try to localize the report following the instructions mentioned in the below link, http://help.pentaho.com/Documentation/5.1/0L0/130/0C0 Try adding Russian characters in the Resource Editor window. Click Ok. Edit the properties file. Russian characters are changed to ???.

      Description

      We are trying to localize a report to Russian language and are following the instructions mentioned in the below link,

      http://help.pentaho.com/Documentation/5.1/0L0/130/0C0

      When trying to enter Russian Characters in the Resource Editor, it gets automatically saved as Question Marks(???). I have tried specifying different encoding formats to the startup script. The encoding formats (-Dfile.encoding) that has been tried are UTF-8, CP1251, ISO-8859-1, ISO 8859-5 to the startup script, but not getting the correct russian characters.

      However, when labels are directly given the value in russian then the russian char are displayed. But when it is coming from properties file, the Russian char are displayed as ??? . I also noticed that the file gets saved with ANSI encoding.
      I have attached a sample prpt report which illustrates the issue.

        PractiTest Integration




          Attachments

            Issue Links

              Activity

                People

                Assignee:
                nprakash Nikhil Prakash
                Reporter:
                nprakash Nikhil Prakash
                Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: