Uploaded image for project: 'Pentaho Reporting and Pentaho Report Designer'
  1. Pentaho Reporting and Pentaho Report Designer
  2. PRD-5113

Line Charts not accepting Timestamp or time formatted data from PDI data source

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Severity: High
    • Resolution: Incomplete
    • Affects Version/s: None
    • Fix Version/s: Backlog
    • Component/s: Report Generation
    • Environment:
      Intel x86 CPU running Windows 7 - 64 bit
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.
    • Operating System/s:
      Windows 7 (64-bit)

      Description

      In PDI 5.0.1 stable (November 15, 2013 release) when transforming data in the "Split Fields" step and using the "Timestamp" data type for the first column, and finally using the "Group By" step, an error would occur as follows:

      Timestamp : Comparing values can not be done with data type : 9

      It was suggested that this had been resolved in later releases, so I went to the CI server and downloaded the latest build of PDI (today's). This fixed the problem in PDI and data previewed properly.

      When the PDI transformation was used as a data source for a Report Designer (November 25, 2013 stable release) Line Chart, the preview of the data source last step (Group By) would show no data. I concluded that libraries within PRD must have the same issues that PDI had. So, I downloaded the latest CI build (#692). This solved the problem of the data preview not showing any data.

      However, if I attempt to use this data source in either of the other two line charts, which support "x-tick-period" attributes, then the chart shows no data. The "legacy" Line Chart does show data, but the x-axis where the timestamp should be displayed only has "..." for each tick. Even if I change the "Type" of the column in the PDI "Split Fields" step, I still get only "...". Following is a sample of the data coming in to PRD.

      2014-06-03 04:00:00 chrapud17 6
      2014-06-03 05:00:00 chrapud17 30
      2014-06-03 06:00:00 chrapud17 30
      2014-06-03 07:00:00 chrapud17 29
      2014-06-03 08:00:00 chrapud17 30

      My conclusion here is that there may still be issues with timestamp data in the Line Chart components.

        Attachments

          Activity

            People

            Assignee:
            mpp4manu Michael Peoples
            Reporter:
            mpp4manu Michael Peoples
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: