Uploaded image for project: 'Pentaho Reporting and Pentaho Report Designer'
  1. Pentaho Reporting and Pentaho Report Designer
  2. PRD-3512

Problem launching Report Designer version 3.7 and 3.8 on Windows 7

    XMLWordPrintable

    Details

    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.

      Description

      http://forums.pentaho.com/showthread.php?82867-Problem-launching-Report-Designer-version-3.7-and-3.8-on-Windows-7

      I have a problem running any version of Report Designer from 3.7 onwards on my Windows 7 PC. I have recently installed Service Pack 1 but the problem existed before doing so.

      When I run report-designer.bat the splash screen appears with the message "Booting Reporting Engine" but this is soon followed by this error message:

      java.lang.IllegalStateException: Booting failed
      at org.pentaho.reporting.designer.core.ReportDesigner.main(ReportDesigner.java:300)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.pentaho.commons.launcher.Launcher.main(Launcher.java:134)
      Caused by: java.lang.NullPointerException
      at java.util.Hashtable.put(Unknown Source)
      at java.util.Properties.setProperty(Unknown Source)
      at java.lang.System.setProperty(Unknown Source)
      at org.pentaho.reporting.designer.core.settings.ProxySettings.applySettings(ProxySettings.java:260)
      at org.pentaho.reporting.designer.core.ReportDesignerBoot.performBoot(ReportDesignerBoot.java:112)
      at org.pentaho.reporting.libraries.base.boot.AbstractBoot.start(AbstractBoot.java:197)
      at org.pentaho.reporting.designer.core.ReportDesigner.main(ReportDesigner.java:297)
      ... 5 more

      Report Designer version 3.6.0-GA.11125 works fine on the same machine.

      I can get these newer versions of Report Designer to run on another PC using Windows XP so I don't think that my downloads are corrupt.

      My java setup appears correct, "java -version" returns the following detail:

      java version "1.6.0_26"
      Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
      Java HotSpot(TM) Client VM (build 20.1-b02, mixed mode, sharing)

      This matches the version information reported by the Java control panel applet.

      Not sure where to take it from here, any help will be greatly appreciated.

        Attachments

          Activity

            People

            Assignee:
            rfellows Rob Fellows (Inactive)
            Reporter:
            tmorgner Thomas Morgner
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: