Uploaded image for project: 'Pentaho Data Integration - Kettle'
  1. Pentaho Data Integration - Kettle
  2. PDI-10258

Cassandra Output with authentication does not work.

    Details

    • PDI Sub-component:
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.
    • Operating System/s:
      Windows 7 (64-bit)

      Description

      Hello PDI developers and users.

      I have a problem and I would like to know if is a problem of my system or "something else", for "something else" I mean a strange behavior of pentaho data integration Cassandra Output Step.

      It's few months that I use the Cassandra Output step to write data in Cassandra and It alway worked well. Until few days ago my Cassandra system configuration had just a single node and no autentification required. It had empty username and empty password, like every example showed in the Cassandra Output Step tutorial or guide.

      Now our Cassandra system required a username and a password for security reason.
      I'm able to write and read with different cassandra clients, for example cassandra-cli, chsql client and other custom applications.

      If I run the same transformation that worked well without useraname and password, obviously now setting the correct username and password in the Cassandra Output Step It doesn't work.

      The stranger thing is that If I click "show schema" in the Cassandra Output Step I'm able to see the schema information, so I'm quite sure that the autentification process in this command works well, but when I try to execute the transformation I can read the follow error in the Transforamtion Logs.
      Code:

      InvalidRequestException(why:You have not logged in)

      It's like the autentification process fails, but this is impossible because I'm able to see the schema information. Is that right?

      In every tutorial and documentation about Cassandra Output Step I always see a configuration without username and password.

      Let me know if someone has ever tried this step with username and password, if someone has positive confirmation about functioning with username and password on cassandra means that there is some problem in my configuration.
      Otherwise please let's check the code of the Cassandra Output Steps, It seems that It doesn't use the autentification during the writing.

      Best Regards Gaetano

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                project admin Triage
                Reporter:
                deepyou Gaetano Fabiano
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: