Uploaded image for project: 'Pentaho BA Platform'
  1. Pentaho BA Platform
  2. BISERVER-3562

As a system admin, I want the pentaho server to run with Tomcat 7.

    XMLWordPrintable

    Details

    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.
    • Sprint:
      5.x Required Defects

      Description

      a. User Definition
      i. System Admin - person responsible for the installation and setup of the system.

      b. Support a more current and stable Tomcat version.
      i. Run under Tomcat version 7.0.0.x
      ii. Use Servlet spec 2.4.
      iii. Do not update installer. Still use Tomcat 6.

      c. Support Tomcat 7 CSRF filter that can be included/used in the Pentaho webapp that will prevent CSRF. See http://www.tomcatexpert.com/blog/2011/05/09/cross-site-request-forgery

      d. Success Criteria
      i. Equal functionality of the server as the previous Tomcat version.
      ii. Test with CSRF enabled.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              jtcornelius Jake Cornelius (Inactive)
              Votes:
              10 Vote for this issue
              Watchers:
              17 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: