Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Unknown Unknown
    • Resolution: Duplicate
    • Affects Version/s: 3.3.0 GA (4.1.0 GA Suite Release)
    • Fix Version/s: None
    • Component/s: Workbench
    • Labels:
      None
    • QA Validation Status:
      Not Yet Validated

      Description

      Setting up a JNDI connection does not seem to work out of the box. To make it work it's necessary to:

      1) grab some simple-jndi-xxxxx.jar from somewhere else (copy from PRD, PDI or PME) and copy to schema-workbench/lib
      2) create schema-workbench/simple-jndi directory
      3) copy/create schema-workbench/simple-jndi/jdbc.properties (again, best to copy from PDI or some such)
      BTW: it is documented in the KB that workbench would look in "$USER_HOME/.pentaho/simple-jndi/default.properties" Not sure about that. The schema-workbench/simple-jndi directory needs to be created in any case, otherwise simple-jndi fails with an exception: "parameter must be a directory".

      Cheers
      Slawo

        Issue Links

          Activity

          Slawomir Chodnicki added a comment -
          Note: on windows it's also necessary to edit the workbench.bat file to include the simple-jndi jar file into the class path
          Chut Yee added a comment -
          There is another problem:

          The JNDI name has to be the same as the database name, else it won't work.

          On the connection screen,
          - key in a JNDI name, say MyDatabase.
          - switch from JNDI to Native (JDBC), you will see the Database Name also takes the value "MyDatabase",

          Schema workbench will use "MyDatabase" as the database name, even though the jndi.properties may be something else, like:
          MyDatabase/url=jdbc:mysql://localhost:3306/mydb
          Chut Yee added a comment -
          Just in case anybody stumbled upon this (like me). It is completely OK to use plain old JDBC for schema workbench.

          The database connection is NOT encoded in the schema at all. It was during the time of publishing that the BI server ask to associate it with a datasource.
          Jared Cornelius added a comment -
          Closing as a duplicate of PSW-101.

            People

            • Assignee:
              Jared Cornelius
              Reporter:
              Slawomir Chodnicki
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: