Pentaho Data Integration - Kettle
  1. Pentaho Data Integration - Kettle
  2. PDI-9792

Generate Report step error out in PDI 4.4 when using excel as output in Window

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 4.4.0 GA (4.8.0 GA Suite Release)
    • Fix Version/s: 4.4.1
    • Component/s: Step
    • Labels:
      None
    • Customer Case:
    • PDI Sub-component:
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.
    • QA Validation Status:
      Not Yet Validated

      Description

      Repro steps:
      1. Use the attached transformation. Change the input and output path to where your local steel-wheels folder is.
      2. Run the transformation using PDF as output. Transformation run without error.
      3. Run the transformation using excel as output. Step error out. Below is the error in log. This only happen with window machine. It works fine in MAC.
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : Unexpected error
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : org.pentaho.di.core.exception.KettleException:
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : There was an unexpected error processing report '\4.8.1 PUC\biserver-ee\pentaho-solutions\steel-wheels\reports\Income Statement.prpt' to produce file '\4.8.1 PUC\biserver-ee\pentaho-solutions\steel-wheels\reports\Income Statement.xls' with processor: Excel.
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : Failed at query: SELECT *
      FROM
           TRIAL_BALANCE
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) :
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : at org.pentaho.di.trans.steps.pentahoreporting.PentahoReportingOutput.processReport(PentahoReportingOutput.java:246)
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : at org.pentaho.di.trans.steps.pentahoreporting.PentahoReportingOutput.processRow(PentahoReportingOutput.java:115)
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : at org.pentaho.di.trans.step.RunThread.run(RunThread.java:50)
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : at java.lang.Thread.run(Thread.java:662)
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : Caused by: org.pentaho.reporting.engine.classic.core.ReportDataFactoryException: Failed at query: SELECT *
      FROM
           TRIAL_BALANCE
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : at org.pentaho.reporting.engine.classic.core.modules.misc.datafactory.sql.SimpleSQLReportDataFactory.queryData(SimpleSQLReportDataFactory.java:258)
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : at org.pentaho.reporting.engine.classic.core.modules.misc.datafactory.sql.SQLReportDataFactory.queryData(SQLReportDataFactory.java:171)
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : at org.pentaho.reporting.engine.classic.core.CompoundDataFactory.queryStatic(CompoundDataFactory.java:135)
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : at org.pentaho.reporting.engine.classic.core.cache.CachingDataFactory.queryInternal(CachingDataFactory.java:431)
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : at org.pentaho.reporting.engine.classic.core.cache.CachingDataFactory.queryStatic(CachingDataFactory.java:184)
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : at org.pentaho.reporting.engine.classic.core.CompoundDataFactory.queryStatic(CompoundDataFactory.java:130)
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : at org.pentaho.reporting.engine.classic.core.CompoundDataFactory.queryData(CompoundDataFactory.java:85)
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : at org.pentaho.reporting.engine.classic.core.states.datarow.ReportDataRow.createDataRow(ReportDataRow.java:97)
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : at org.pentaho.reporting.engine.classic.core.states.datarow.DefaultFlowController.performQuery(DefaultFlowController.java:188)
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : at org.pentaho.reporting.engine.classic.core.states.process.ProcessState.initializeForMasterReport(ProcessState.java:260)
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : at org.pentaho.reporting.engine.classic.core.layout.output.AbstractReportProcessor.prepareReportProcessing(AbstractReportProcessor.java:477)
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : at org.pentaho.reporting.engine.classic.core.layout.output.AbstractReportProcessor.processReport(AbstractReportProcessor.java:1647)
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : at org.pentaho.reporting.engine.classic.core.modules.output.table.xls.ExcelReportUtil.createXLS(ExcelReportUtil.java:194)
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : at org.pentaho.di.trans.steps.pentahoreporting.PentahoReportingOutput.processReport(PentahoReportingOutput.java:228)
      2013/04/18 16:21:00 - Generate Reports.0 - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : ... 3 more
      2013/04/18 16:21:00 - Generate Reports.0 - Finished processing (I=0, O=0, R=1, W=0, U=0, E=1)
      2013/04/18 16:21:00 - Spoon - The transformation has finished!!
      2013/04/18 16:21:00 - Schedule_testGREG - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : Errors detected!
      2013/04/18 16:21:00 - Schedule_testGREG - ERROR (version 4.4.1-GA, build 18329 from 2013-04-17 12.31.49 by buildguy) : Errors detected!
      2013/04/18 16:21:00 - Schedule_testGREG - Schedule_testGREG
      2013/04/18 16:21:00 - Schedule_testGREG - Schedule_testGREG

        Activity

        Marc Batchelor added a comment -
        Please retest in 4.4.1. I think these class issues should be resolved.

          People

          • Assignee:
            Li Deng
            Reporter:
            Li Deng
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: