Uploaded image for project: 'Pentaho Data Integration - Kettle'
  1. Pentaho Data Integration - Kettle
  2. PDI-9317

Pentaho Reporting Ouput - Error when generate Excel: NoSuchMethodError: org.apache.poi.hssf.util.HSSFColor.getIndexHash

    Details

    • Type: Bug
    • Status: Closed
    • Severity: Medium
    • Resolution: Duplicate
    • Affects Version/s: 4.4.0 GA (4.8.0 GA Suite Release)
    • Fix Version/s: None
    • Component/s: Step
    • Labels:
      None
    • PDI Sub-component:
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.
    • Operating System/s:
      Windows XP

      Description

      2013/02/15 09:57:11 - Génération de rapports Pentaho.0 - ERROR (version 4.4.0-stable, build 17588 from 2012-11-21 16.02.21 by buildguy) : java.lang.NoSuchMethodError: org.apache.poi.hssf.util.HSSFColor.getIndexHash()Ljava/util/Hashtable;
      2013/02/15 09:57:11 - Génération de rapports Pentaho.0 - ERROR (version 4.4.0-stable, build 17588 from 2012-11-21 16.02.21 by buildguy) : at org.pentaho.reporting.engine.classic.core.modules.output.table.xls.helper.StaticExcelColorSupport.<clinit>(StaticExcelColorSupport.java:57)

      1. Genere TB.ktr
        17 kB
        Stéphane Nobilet
      2. orientation_tb_territoire_test_validation.prpt
        4 kB
        Jens Bleuel
      3. orientation_tb_territoire_test.prpt
        5 kB
        Stéphane Nobilet
      1. copie.PNG
        127 kB

        Issue Links

          Activity

          snobilet Stéphane Nobilet added a comment -

          There is no problem with PDF, CSV .... only with Excel and Excel 2007

          snobilet Stéphane Nobilet added a comment -

          I use PRD 3.9.1

          jbleuel Jens Bleuel added a comment -

          Stéphane, could you attach a sample PRD and transformation for easier reproduction?

          snobilet Stéphane Nobilet added a comment -

          I do ...
          Thanks

          jbleuel Jens Bleuel added a comment -

          Thanks for the reproduction sample.

          For reproduction:

          • use the orientation_tb_territoire_test_validation.prpt (I cleaned out the data sets)
          • Change the constants in step "Ajout constantes"

          It can be reproduced in 4.4.0 but it is no longer an issue in 5.0.

          jbleuel Jens Bleuel added a comment -

          Closing as duplicate of PDI-9156


            People

            • Assignee:
              Unassigned
              Reporter:
              snobilet Stéphane Nobilet
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: