Uploaded image for project: 'Pentaho Data Integration - Kettle'
  1. Pentaho Data Integration - Kettle
  2. PDI-9205

Failure starting spoon on linux - org.eclipse.swt.SWTError: XPCOM error -1041039104

    Details

    • Type: Bug
    • Status: Closed
    • Severity: Medium
    • Resolution: Duplicate
    • Affects Version/s: 4.4.0 GA (4.8.0 GA Suite Release)
    • Fix Version/s: Not Planned
    • Component/s: Spoon / User Interface
    • Labels:
      None
    • Environment:
      RHEL 6.3
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.
    • Operating System/s:
      RedHat Enterprise Linux 6

      Description

      Starting spoon fails with the error:

      [pdi@aupdc00-pdi01s 4.4.0.GA]$ export DISPLAY=10.80.0.97:0.0
      [pdi@aupdc00-pdi01s 4.4.0.GA]$ cd design-tools/data-integration/
      [pdi@aupdc00-pdi01s data-integration]$ ./spoon.sh
      /u00/4.4.0.GA/design-tools/data-integration
      /u00/4.4.0.GA/design-tools/data-integration
      DEBUG: Using JAVA_HOME
      DEBUG: Found Pentaho License two folders up
      DEBUG: _PENTAHO_JAVA_HOME=/u00/java/1.6.0_38
      DEBUG: _PENTAHO_JAVA=/u00/java/1.6.0_38/bin/java
      DEBUG: PENTAHO_INSTALLED_LICENSE_PATH=/u00/4.4.0.GA/design-tools/data-integration/../../.installedLicenses.xml
      WARN 25-01 09:25:41,008 - Unable to load Hadoop Configuration from "file:///u00/4.4.0.GA/design-tools/data-integration/plugins/pentaho-big-data-plugin/hadoop-configurations/mapr". For more information enable debug logging.
      INFO 25-01 09:25:44,594 - Spoon - Logging goes to file:///tmp/spoon_fe75d236-6674-11e2-9053-6f7f283ecf07.log
      org.eclipse.swt.SWTError: XPCOM error -1041039104
      at org.eclipse.swt.browser.Mozilla.error(Unknown Source)
      at org.eclipse.swt.browser.Mozilla.initFactories(Unknown Source)
      at org.eclipse.swt.browser.Mozilla.create(Unknown Source)
      at org.eclipse.swt.browser.Browser.<init>(Unknown Source)
      at org.pentaho.ui.xul.swt.tags.SwtBrowser.createBrowser(SwtBrowser.java:230)
      at org.pentaho.ui.xul.swt.tags.SwtBrowser.layout(SwtBrowser.java:160)
      at org.pentaho.ui.xul.impl.XulParser.parse(XulParser.java:171)
      at org.pentaho.ui.xul.impl.XulParser.parse(XulParser.java:156)
      at org.pentaho.ui.xul.impl.XulParser.parse(XulParser.java:156)
      at org.pentaho.ui.xul.impl.XulParser.parse(XulParser.java:156)
      at org.pentaho.ui.xul.impl.XulParser.parseDocument(XulParser.java:70)
      at org.pentaho.ui.xul.impl.AbstractXulLoader.loadXul(AbstractXulLoader.java:119)
      at org.pentaho.ui.xul.swt.SwtXulLoader.loadXul(SwtXulLoader.java:112)
      at org.pentaho.ui.xul.swt.SwtXulLoader.loadXul(SwtXulLoader.java:106)
      at org.pentaho.ui.xul.impl.AbstractXulLoader.loadXul(AbstractXulLoader.java:244)
      at org.pentaho.agilebi.spoon.perspective.AbstractPerspective.<init>(AbstractPerspective.java:71)

        Issue Links

          Activity

          doffe Evgeny Minkevich added a comment -
          jcornelius Jared Cornelius added a comment -

          Closing as a duplicate of PDI-8730.


            People

            • Assignee:
              Unassigned
              Reporter:
              doffe Evgeny Minkevich
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: