Details

    • PDI Sub-component:
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.

      Description

      Hi,

      When I use a MetaData Injection Step, I can't catch variables (with GetVariables) which are set before (in parent job or parent transformation)

      I have found on the forum this bug (http://forums.pentaho.com/showthread.php?84108-Metadata-Injection-and-Variables) but I don't find it on jira.

      Thx.

      1. read_csv_file.ktr
        19 kB
        Jens Bleuel
      2. use_metainject_step.ktr
        28 kB
        Jens Bleuel

        Activity

        Hide
        yob49h Yoann Boudon added a comment -

        ok, if I set my variable on the scope "Valid in the Java Virtual Machine", I can get it in the transformation which is injected.
        But it doesn't run with the others scopes.

        Show
        yob49h Yoann Boudon added a comment - ok, if I set my variable on the scope "Valid in the Java Virtual Machine", I can get it in the transformation which is injected. But it doesn't run with the others scopes.
        Hide
        jmahoney John Mahoney added a comment -

        I believe this may be a duplicate see PDI-7757.

        Show
        jmahoney John Mahoney added a comment - I believe this may be a duplicate see PDI-7757 .
        Hide
        jbleuel Jens Bleuel added a comment -

        This issue was confirmed in 4.3 but is no longer reproducible in 4.4.0 (see test cases attached, the named parameters from the parent are taken into account).
        Closing as fixed in 4.4.0

        Show
        jbleuel Jens Bleuel added a comment - This issue was confirmed in 4.3 but is no longer reproducible in 4.4.0 (see test cases attached, the named parameters from the parent are taken into account). Closing as fixed in 4.4.0
        Hide
        jbleuel Jens Bleuel added a comment - - edited

        Needs validation in 5.0. It can not be validated until PDI-9560 is fixed.

        Show
        jbleuel Jens Bleuel added a comment - - edited Needs validation in 5.0. It can not be validated until PDI-9560 is fixed.

          People

          • Assignee:
            Unassigned
            Reporter:
            yob49h Yoann Boudon
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: