Details

    • Type: Bug
    • Status: Closed
    • Severity: High
    • Resolution: Fixed
    • Affects Version/s: 4.4.0 GA (4.8.0 GA Suite Release)
    • Component/s: Instaview
    • Labels:
      None
    • Environment:
      Ubuntu 12 64-bit VM
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.

      Description

      After running the PDI installer from 10/16 and starting up in Instaview, I created a CSV Input pointing at "customers-100.txt" from the samples directory. When the ETL-Model-Data Cache procedure ran, I got an error saying "Unable to connect (localhost:50000): Connection refused. See screenshot above for full error.

      I did a "ps -aef | grep monet" and it appears that the monetdb server was for some reason created on port 50006, not 50000, this may be the cause of the problem. Also I have two entries in my hosts file for 127.0.0.1, one for localhost and one for my hostname. This shouldn't matter but I mention it just in case. I tried to comment out the hostname one but that made no difference.

        Issue Links

          Activity

          mburgess Matt Burgess added a comment -

          Uploaded screenshot of error

          rfellows Rob Fellows added a comment -

          I ran the installer on my ubuntu 12 VM and it all seemed to work just fine for me. The error message you are getting leads me to believe that you already had a shared connection created for (AgileBI) with a previous install/archive build that was set up to operate on the default port of 50000. If the share connection already exists, we don't overwrite it.

          at some point the installer decides which port to use for our instance of monetdb, not sure if its based on open ports or hard coded to 50006 now. that is why you are seeing a different port now.

          Can you tell if this is the case you have in your environment, Matt?

          rfellows Rob Fellows added a comment -

          I am able to forcibly reproduce this by changing the port settings (in 2 places) in my ~/.kettle/share.xml file for the AgileBI connection from 50006 to 50000. This results in the same error message for me.

          getting into this scenario is off the happy path, obviously. However, what do we want to do about it?

          It all depends on if you've previously had a shared connection setup on a different port. We don't overwrite the shared connection, we just use it. So, is that something we want to change? Always overwrite the shared connection? If so, then the only way to configure it is through the .spoonrc file. And that would be limited to what we pull from there (port, db name). Everything else, in particular DBMS and user/pwd wouldn't be able to be changed.

          I suppose we might be able to check to see if it exists AND is monetdb, then overwrite it.

          Assigning to Doug for how to proceed.

          rfellows Rob Fellows added a comment -

          there is also a suspicious value in the spoonrc file that gets written out as part of the installer.

          MonetDBDefaultMClientPath=**unknown variable mclient_bat_path.escape_backslashes**

          i've let ramaiz know, he's fixing it. i don't think this is the root cause of our problem though. see comments above for that.

          rfellows Rob Fellows added a comment -

          After talking with Doug, we've decided to overwrite the shared connection on startup if one already exists and is using MonetDB.

          rfellows Rob Fellows added a comment -

          will be available in the 4.8.0-GA RC3 build of the installers

          gdavid Golda Thomas added a comment -

          In Ubuntu 12x64 VM I tried the latest pdi 4.4 installer and there is no issue connecting to Monet Db.
          There is no suspicious entry in the spoon rc file when I did the pdi installer.
          Tested this in my Ubuntu 12 VM

          mburgess Matt Burgess added a comment -

          I also verified this using an Ubuntu 12 64-bit VM using the RC3 PDI installer and no longer have the issues connecting to MonetDB.

          gdavid Golda Thomas added a comment -

          Validated this issue using the pdi 4.4 installer build on Oct 25/2012


            People

            • Assignee:
              gdavid Golda Thomas
              Reporter:
              mburgess Matt Burgess
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: