Details

    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.

      Description

      When I hit run on an instaview that uses parameters, I get an exception - see attached screenshot

        Activity

        Hide
        jganoff Jordan Ganoff (Inactive) added a comment -

        Found a problem with the check to determine if a transformation was externally changed for new projects that only affect parameterized templates. Since we don't have to edit a step when parameters are in play the transformation metadata hasn't been loaded into the session and there's nothing to check for changes against. This leads to a NPE.

        To validate, edit one of the templates to add a parameter. Create a new Instaview against that template and use a valid parameter value. You should be able to run the Instaview and have it complete successfully.

        Show
        jganoff Jordan Ganoff (Inactive) added a comment - Found a problem with the check to determine if a transformation was externally changed for new projects that only affect parameterized templates. Since we don't have to edit a step when parameters are in play the transformation metadata hasn't been loaded into the session and there's nothing to check for changes against. This leads to a NPE. To validate, edit one of the templates to add a parameter. Create a new Instaview against that template and use a valid parameter value. You should be able to run the Instaview and have it complete successfully.

          People

          • Assignee:
            tband Tyler Band (Inactive)
            Reporter:
            dmoran Doug Moran
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: