Uploaded image for project: 'Pentaho Data Integration - Kettle'
  1. Pentaho Data Integration - Kettle
  2. PDI-4033

PDI archive based installation: launch-designer.bat references a missing set-pentaho-java.bat

    Details

    • Type: Bug
    • Status: Closed
    • Severity: Medium
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.0.0 GA, 4.0.1
    • Fix Version/s: None
    • Component/s: Installer
    • Labels:
      None
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.

      Description

      Out of this, the used JRE is not predictable.
      Not an issue when the installer is used, Spoon.bat is modified then.

        Issue Links

          Activity

          lcheng Lee Cheng added a comment -

          Added set-pentaho-java.bat and set-pentaho-java.sh to the package-res directory

          Modified launch-designer.sh to call set-pentaho-java.sh
          launch-designer.bat was already calling set-pentaho-java.bat

          lcheng Lee Cheng added a comment - - edited

          Will be available for testing in a PDI 4.0.1 nightly dated after 7/27/2010 2PM

          Need to verify the following:

          set-pentaho-java.bat and set-pentaho.sh files should now exist in the same directory as the launch-designer files.
          Both the launch-designer files should call these files and end up using the pentaho supplied JRE.

          gdavid Golda Thomas added a comment -

          Tested this issue using the PDI 4.0.1 build on 7/28/2010 and this issue is resolved.
          set-pentaho-java.bat is available in the pdi-ee folder an launch-designer.bat file calls the set-pentaho-java.bat file.

          gdavid Golda Thomas added a comment -

          Validated using the PDI 4.0.1 build on 7/28/2010

          gdavid Golda Thomas added a comment -

          rem This bat file starts the Data Integration Designer (client\spoon.bat)

          setlocal

          if exist "%~dp0jre" call "%~dp0set-pentaho-java.bat" "%~dp0jre"
          if not exist "%~dp0jre" call "%~dp0set-pentaho-java.bat"

          rem — Set home directory of designer

          set SCRIPT_HOME=%CD%
          set DI-UI-HOME=%SCRIPT_HOME%\data-integration

          rem – start designer

          cd %DI-UI-HOME%
          call spoon.bat

          :quit
          endlocal

          jbleuel Jens Bleuel added a comment -

          Tested with 4.0.1 GA: "... and end up using the pentaho supplied JRE."
          --> They do not use the pentaho supplied JRE.

          This can be tested with adding
          set JAVA_HOME=
          to the launcher.bat and start-servers.bat
          and adding a PAUSE at the end of the set-pentaho-java.bat

          Both files (launcher.bat and start-servers.bat) need to be changed to use the JRE below data-integration-server. It should be discussed if the location of the JRE folder should be moved to one directory above or add "data-integration-server\" in both start up scripts:

          if exist "%~dp0data-integration-server\jre" call "%~dp0set-pentaho-java.bat" "%~dp0data-integration-server\jre"
          if not exist "%~dp0data-integration-server\jre" call "%~dp0set-pentaho-java.bat"

          Similar changes needed in the .sh scripts.

          jbleuel Jens Bleuel added a comment -

          set-pentaho-java was replaced by set-pentaho-env and the logic was changed since the report of this bug.

          Closing this as Cannot reproduce in 4.3 nor 4.4.
          We have a PENTAHO_JAVA variable that is set by call "%~dp0set-pentaho-env.bat". Please reopen when needed.


            People

            • Assignee:
              project admin Triage
              Reporter:
              jbleuel Jens Bleuel
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: