Pentaho Data Integration - Kettle
  1. Pentaho Data Integration - Kettle
  2. PDI-3581

DB-based repositories that no longer exist show up in the repo list at Spoon startup, and can't be removed

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 4.0.0 GA
    • Fix Version/s: 4.0.0 GA
    • Component/s: None
    • Labels:
      None
    • Environment:
      Ubuntu 9.10 32-bit x86, Java 1.6.0, PDI 4.0 Preview nightly from 3/29/2010
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.
    • Operating System/s:
      Ubuntu 8.x
    • QA Validation Status:
      Validated by QA
    • CI Build:
      1210

      Description

      1. Download and unpack Kettle
      2. Run start-servers.sh
      3. Run spoon.sh
      4. Create a DB-based repository
      5. Quit Kettle
      6. Delete the pdi-ee directory (remove Kettle, in other words)
      7. Reinstall Kettle (or unpack a new PDI build)
      8. Start the new instance of Kettle
      9. The old repository you created is visible in the repo list upon startup
      10. Select the old repository, then click the Delete button

      Result: The old repository is not removed from the list, and the following error occurs (the repository listing is in fact removed, but it stays in the list; restart Kettle and you'll see that it no longer appears):

      INFO 29-03 10:53:42,528 - SetElements on listbox called: collection has 1 rows
      Changed to: file:///home/valour/Desktop/pdi-ee/data-integration/docs/English/welcome/kettle_document_map.html
      org.pentaho.di.core.exception.KettleException:
      Error connecting to the repository!

      No repository exists on the specified connection.

      To create a repository, select the Edit' button followed by the 'Create or upgrade' button.

      at org.pentaho.di.repository.kdr.delegates.KettleDatabaseRepositoryConnectionDelegate.connect(KettleDatabaseRepositoryConnectionDelegate.java:141)
      at org.pentaho.di.repository.kdr.KettleDatabaseRepository.connect(KettleDatabaseRepository.java:173)
      at org.pentaho.di.repository.kdr.KettleDatabaseRepository.connect(KettleDatabaseRepository.java:163)
      at org.pentaho.di.ui.repository.RepositoriesHelper.loginToRepository(RepositoriesHelper.java:211)
      at org.pentaho.di.ui.repository.controllers.RepositoriesController.login(RepositoriesController.java:137)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.pentaho.ui.xul.impl.AbstractXulDomContainer.invoke(AbstractXulDomContainer.java:323)
      at org.pentaho.ui.xul.impl.AbstractXulComponent.invoke(AbstractXulComponent.java:131)
      at org.pentaho.ui.xul.impl.AbstractXulComponent.invoke(AbstractXulComponent.java:119)
      at org.pentaho.ui.xul.swt.tags.SwtTextbox.access$300(SwtTextbox.java:21)
      at org.pentaho.ui.xul.swt.tags.SwtTextbox$2.handleEvent(SwtTextbox.java:70)
      at org.eclipse.swt.widgets.EventTable.sendEvent(Unknown Source)
      at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
      at org.eclipse.swt.widgets.Display.runDeferredEvents(Unknown Source)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Unknown Source)
      at org.eclipse.jface.window.Window.runEventLoop(Window.java:820)
      at org.eclipse.jface.window.Window.open(Window.java:796)
      at org.pentaho.ui.xul.swt.tags.SwtDialog.show(SwtDialog.java:313)
      at org.pentaho.ui.xul.swt.tags.SwtDialog.show(SwtDialog.java:265)
      at org.pentaho.di.ui.repository.RepositoriesDialog.show(RepositoriesDialog.java:79)
      at org.pentaho.di.ui.spoon.Spoon.selectRep(Spoon.java:6209)
      at org.pentaho.di.ui.spoon.Spoon.start(Spoon.java:6357)
      at org.pentaho.di.ui.spoon.Spoon.main(Spoon.java:539)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.pentaho.commons.launcher.Launcher.main(Launcher.java:110)
      Caused by: org.pentaho.di.core.exception.KettleException:

      No repository exists on the specified connection.

      To create a repository, select the Edit' button followed by the 'Create or upgrade' button.

      at org.pentaho.di.repository.kdr.delegates.KettleDatabaseRepositoryConnectionDelegate.verifyVersion(KettleDatabaseRepositoryConnectionDelegate.java:191)
      at org.pentaho.di.repository.kdr.delegates.KettleDatabaseRepositoryConnectionDelegate.connect(KettleDatabaseRepositoryConnectionDelegate.java:120)
      ... 30 more
      DEBUG 29-03 10:54:26,451 - updateMenu called. schedulingEnabled is false

        Activity

        Ramaiz Mansoor added a comment -

        Fixed

        Golda David added a comment -

        Tested this issue using the nightly build for pdi from 4-20-2010 and this issue is resolved.
        Removing repositories did not give any error.

        Golda David added a comment -

        Validated using the nightly build for pdi ee from 4-20-2010


          People

          • Assignee:
            Golda David
            Reporter:
            Jem Matzan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: