Uploaded image for project: 'Pentaho Data Integration - Kettle'
  1. Pentaho Data Integration - Kettle
  2. PDI-3564

Cannot create a new Transformation after connecting to an old file based repository - respositories.xml is pointing to a previous install

    Details

    • Type: Bug
    • Status: Closed
    • Severity: Medium
    • Resolution: Fixed
    • Affects Version/s: 4.0.0 GA
    • Fix Version/s: 4.0.0 GA
    • Component/s: Repository (general)
    • Labels:
      None
    • Environment:
      NIGHTLY BUILD 3/29 4:41am
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.
    • Operating System/s:
      Windows XP

      Description

      I Connected to an file based respository, and tried to create a new Transformation, but it fails & generates an error message. (below)

      Will looked at it with me and the file repository was created on a previous install. Repositories.xml (attached) is pointing to the old location.

      C:\Documents and Settings\RCook\.kettle

      Repro:
      1. Connect to old file based respository,
      2. File > New > Transformation
      Observe An error dialog displays - as follows:
      Unable to get root object ids for extension [.kdb]
      Could not list the contents of "file:///C:/Pentaho/Dry-Runs/pdi-ee/pdi-ee/kettle" because it is not a folder.

      org.pentaho.di.core.exception.KettleException:
      Unable to get root object ids for extension [.kdb]
      Could not list the contents of "file:///C:/Pentaho/Dry-Runs/pdi-ee/pdi-ee/kettle" because it is not a folder.

      at org.pentaho.di.repository.filerep.KettleFileRepository.getRootObjectIDs(KettleFileRepository.java:518)
      at org.pentaho.di.repository.filerep.KettleFileRepository.getDatabaseIDs(KettleFileRepository.java:413)
      at org.pentaho.di.repository.filerep.KettleFileRepository.readTransSharedObjects(KettleFileRepository.java:908)
      at org.pentaho.di.ui.spoon.Spoon.newTransFile(Spoon.java:3682)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.pentaho.ui.xul.impl.AbstractXulDomContainer.invoke(AbstractXulDomContainer.java:323)
      at org.pentaho.ui.xul.impl.AbstractXulComponent.invoke(AbstractXulComponent.java:131)
      at org.pentaho.ui.xul.impl.AbstractXulComponent.invoke(AbstractXulComponent.java:119)
      at org.pentaho.ui.xul.swt.tags.SwtMenuitem.access$100(SwtMenuitem.java:24)
      at org.pentaho.ui.xul.swt.tags.SwtMenuitem$1.widgetSelected(SwtMenuitem.java:74)
      at org.eclipse.swt.widgets.TypedListener.handleEvent(Unknown Source)
      at org.eclipse.swt.widgets.EventTable.sendEvent(Unknown Source)
      at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
      at org.eclipse.swt.widgets.Display.runDeferredEvents(Unknown Source)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Unknown Source)
      at org.pentaho.di.ui.spoon.Spoon.readAndDispatch(Spoon.java:1144)
      at org.pentaho.di.ui.spoon.Spoon.start(Spoon.java:6389)
      at org.pentaho.di.ui.spoon.Spoon.main(Spoon.java:539)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.pentaho.commons.launcher.Launcher.main(Launcher.java:110)
      Caused by: org.apache.commons.vfs.FileNotFolderException: Could not list the contents of "file:///C:/Pentaho/Dry-Runs/pdi-ee/pdi-ee/kettle" because it is not a folder.
      at org.apache.commons.vfs.provider.AbstractFileObject.getChildren(AbstractFileObject.java:628)
      at org.pentaho.di.repository.filerep.KettleFileRepository.getRootObjectIDs(KettleFileRepository.java:505)
      ... 25 more

        Activity

        mcasters Matt Casters added a comment -

        Also fixed

        gdavid Golda Thomas added a comment -

        Tested and validated using the nightly build for pdi ee from 5/13/2010.


          People

          • Assignee:
            mcasters Matt Casters
            Reporter:
            rcook Ruth Cook
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: