Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Step
    • Labels:
      None

      Description

      Some WebServices use cookies for e.g. Session Handling.
      I implemented a singleton-class that handles the httpClient.

        Issue Links

          Activity

          Monika Stoib added a comment -
          HttpClient vHttpClient = new HttpClient();
          has to be replaced in the WebService.java by the following code :
          HelpHttpClient helpclient = HelpHttpClient.getInstance();
          HttpClient vHttpClient = helpclient.getHttpClient();
          David Kincade added a comment -
          Thank you for the patch. However, since this is commonly run in a multi-user multi-threaded environment, the singleton pattern is a dangerous solution.

          Can you please provide a patch that will work in a multi-user multi-threaded environment.
          Jens Bleuel added a comment -
          Duplicate of PDI-2186

            People

            • Assignee:
              Unassigned User
              Reporter:
              Monika Stoib
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: