Pentaho Analysis - Mondrian
  1. Pentaho Analysis - Mondrian
  2. MONDRIAN-920

mondrian/olap4j: inconsistent measure's member type?

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Component/s: None
    • Labels:
      None
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.
    • Operating System/s:
      Windows XP

      Description

      Hi,
      I am finding that member [Measures].[Store Sales] (which is a Measure) has memberType MEASURE when accessed from hierarchy.getDefaultMember() while it has type REGULAR when accessed from the list of members of the relevant level.

      I am accessing Mondrian through the Olap4j API.

      I am using the latest version of Olap4j (trunk, built on April 6th 2011) and mondrian-3.3-SNAPSHOT obtained from the ivy repositories also on April 6th.

      I can reproduce this reliably against the Foodmart database.

        Activity

        Unassigned User added a comment -

        If you are a Pentaho Subscription customer, you may contact support and request that this case be reviewed/re-prioritized.

        Julian Hyde added a comment -

        I wrote a test case that acquired the same member in different ways. It always came back with type MEASURE.

        How exactly did you "access [it] from the list of members of the relevant level"?

        Note that the default member of the Measures hierarchy is Unit Sales. You must have altered your schema if Store Sales is the default measure.

        Test case checked in as change 14194.

        Golda David added a comment -

        Closing this issue since this cannot be reproduced.
        However if this issue occurs again please create a bug or reopen this issue.


          People

          • Assignee:
            Julian Hyde
            Reporter:
            Michele Rossi
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: