Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Unknown Unknown
    • Resolution: Fixed
    • Affects Version/s: None
    • Component/s: None
    • Labels:
      None
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.

      Description

      If I run this query with the latest CI build of mondrian:

      select NON EMPTY

      {[Measures].[Actual]}

      ON COLUMNS,
      NON EMPTY Hierarchize(Union(Crossjoin(

      {[Department].[All Departments]}, {[Positions].[All Positions]}), Crossjoin({[Department].[All Departments]}

      , [Positions].[All Positions].Children))) ON ROWS
      from [Quadrant Analysis]
      where Except([Region].[All Regions].Children,

      {[Region].[All Regions].[Central]}

      )

      It validates as mdx, but the important sql generated is this:

      [Department].[(All)], [Positions].[Positions]]: executing sql [select `QUADRANT_ACTUALS`.`POSITIONTITLE` as `c0` from `QUADRANT_ACTUALS` as `QUADRANT_ACTUALS` where `QUADRANT_ACTUALS`.`REGION` = 'Western' group by `QUADRANT_ACTUALS`.`POSITIONTITLE` order by ISNULL(`QUADRANT_ACTUALS`.`POSITIONTITLE`), `QUADRANT_ACTUALS`.`POSITIONTITLE` ASC]

      I appears if you use except in the slicer, it just uses the last member in the set.

        Activity

        Julian Hyde added a comment -

        Problem is that mondrian evaluates the slicer twice (for good reason) but the first evaluation contaminates the evaluation context for the second evaluation. Will check in fix shortly.

        Julian Hyde added a comment -

        I've fixed a very similar case in change 13096. The equivalent for your query would be

        where Except([Region].Children,

        {[Region].[All Regions].[Central]}

        )

        Note that this query implicitly inherits the current member of the [Region] hierarchy from the context; this should be [Region].[All Regions], but it was getting corrupted.

        I can't reproduce the issue if I try to translate your query into the FoodMart schema. I'm going to assume that I've fixed it, but if not, please reopen the bug.

        Jake Cornelius added a comment -

        please update the fixed in version on this, thanks

        Vikram NS added a comment -

        tested for Mondrian using the build no biserver-ee-3.7.0-RC1,paz-plugin-ee-3.9.0-RC1.zip on 10/05/2010.

        Vikram NS added a comment -

        tested for Mondrian using the build no biserver-ee-3.7.0-RC1,paz-plugin-ee-3.9.0-RC1.zip on 10/05/2010.


          People

          • Assignee:
            Julian Hyde
            Reporter:
            Tom Barber
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: