Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Severe Severe
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.

      Description

      Results: Error:
      mondrian.resource.ChainableRuntimeException: Internal
      error: Error while executing query [select

      {[Measures]. [Unit Sales]}

      ON columns,
      Order(Except([Promotion Media].[Media
      Type].Members,

      {[Promotion Media].[All Media].[No Media]}

      ), [Measures].[Unit Sales], DESC) ON rows
      from [Sales]
      where ([Time].[1997], [Customers])
      ]
      at mondrian.olap.MondrianResource.newInternal
      (MondrianResource.java:45)
      at mondrian.olap.Util.newError(Util.java:445)
      at mondrian.rolap.RolapConnection.execute
      (RolapConnection.java:213)
      at
      mondrian.web.servlet.MDXQueryServlet.processRequest
      (MDXQueryServlet.java:78)
      at mondrian.web.servlet.MDXQueryServlet.doGet
      (MDXQueryServlet.java:200)
      at javax.servlet.http.HttpServlet.service
      (HttpServlet.java:740)
      at javax.servlet.http.HttpServlet.service
      (HttpServlet.java:853)
      at
      org.apache.catalina.core.ApplicationFilterChain.internalDo
      Filter(ApplicationFilterChain.java:247)
      at
      org.apache.catalina.core.ApplicationFilterChain.doFilter
      (ApplicationFilterChain.java:193)
      at
      org.apache.catalina.core.StandardWrapperValve.invoke
      (StandardWrapperValve.java:256)
      at
      org.apache.catalina.core.StandardPipeline$StandardPipeli
      neValveContext.invokeNext(StandardPipeline.java:643)
      at org.apache.catalina.core.StandardPipeline.invoke
      (StandardPipeline.java:480)
      at org.apache.catalina.core.ContainerBase.invoke
      (ContainerBase.java:995)
      at
      org.apache.catalina.core.StandardContextValve.invoke
      (StandardContextValve.java:191)
      at
      org.apache.catalina.core.StandardPipeline$StandardPipeli
      neValveContext.invokeNext(StandardPipeline.java:643)
      at org.apache.catalina.core.StandardPipeline.invoke
      (StandardPipeline.java:480)
      at org.apache.catalina.core.ContainerBase.invoke
      (ContainerBase.java:995)
      at org.apache.catalina.core.StandardContext.invoke
      (StandardContext.java:2415)
      at org.apache.catalina.core.StandardHostValve.invoke
      (StandardHostValve.java:180)
      at
      org.apache.catalina.core.StandardPipeline$StandardPipeli
      neValveContext.invokeNext(StandardPipeline.java:643)
      at
      org.apache.catalina.valves.ErrorDispatcherValve.invoke
      (ErrorDispatcherValve.java:171)
      at
      org.apache.catalina.core.StandardPipeline$StandardPipeli
      neValveContext.invokeNext(StandardPipeline.java:641)
      at org.apache.catalina.valves.ErrorReportValve.invoke
      (ErrorReportValve.java:172)
      at
      org.apache.catalina.core.StandardPipeline$StandardPipeli
      neValveContext.invokeNext(StandardPipeline.java:641)
      at org.apache.catalina.core.StandardPipeline.invoke
      (StandardPipeline.java:480)
      at org.apache.catalina.core.ContainerBase.invoke
      (ContainerBase.java:995)
      at org.apache.catalina.core.StandardEngineValve.invoke
      (StandardEngineValve.java:174)
      at
      org.apache.catalina.core.StandardPipeline$StandardPipeli
      neValveContext.invokeNext(StandardPipeline.java:643)
      at org.apache.catalina.core.StandardPipeline.invoke
      (StandardPipeline.java:480)
      at org.apache.catalina.core.ContainerBase.invoke
      (ContainerBase.java:995)
      at org.apache.coyote.tomcat4.CoyoteAdapter.service
      (CoyoteAdapter.java:223)
      at org.apache.coyote.http11.Http11Processor.process
      (Http11Processor.java:594)
      at
      org.apache.coyote.http11.Http11Protocol$Http11Connec
      tionHandler.processConnection(Http11Protocol.java:392)
      at org.apache.tomcat.util.net.TcpWorkerThread.runIt
      (PoolTcpEndpoint.java:565)
      at
      org.apache.tomcat.util.threads.ThreadPool$ControlRunna
      ble.run(ThreadPool.java:619)
      at java.lang.Thread.run(Thread.java:536)
      Caused by: java.lang.ClassCastException
      at mondrian.olap.fun.FunUtil.getMemberArg
      (FunUtil.java:163)
      at mondrian.olap.fun.TupleFunDef.evaluate
      (TupleFunDef.java:61)
      at mondrian.rolap.RolapEvaluator.xx
      (RolapEvaluator.java:129)
      at mondrian.olap.FunCall.evaluate(FunCall.java:247)
      at mondrian.olap.fun.SetFunDef.evaluate
      (SetFunDef.java:56)
      at mondrian.rolap.RolapEvaluator.xx
      (RolapEvaluator.java:129)
      at mondrian.olap.FunCall.evaluate(FunCall.java:247)
      at mondrian.rolap.RolapResult.executeAxis
      (RolapResult.java:150)
      at mondrian.rolap.RolapResult.<init>(RolapResult.java:70)
      at mondrian.rolap.RolapConnection.execute
      (RolapConnection.java:198)
      ... 33 more
      caused by
      java.lang.ClassCastException
      at mondrian.olap.fun.FunUtil.getMemberArg
      (FunUtil.java:163)
      at mondrian.olap.fun.TupleFunDef.evaluate
      (TupleFunDef.java:61)
      at mondrian.rolap.RolapEvaluator.xx
      (RolapEvaluator.java:129)
      at mondrian.olap.FunCall.evaluate(FunCall.java:247)
      at mondrian.olap.fun.SetFunDef.evaluate
      (SetFunDef.java:56)
      at mondrian.rolap.RolapEvaluator.xx
      (RolapEvaluator.java:129)
      at mondrian.olap.FunCall.evaluate(FunCall.java:247)
      at mondrian.rolap.RolapResult.executeAxis
      (RolapResult.java:150)
      at mondrian.rolap.RolapResult.<init>(RolapResult.java:70)
      at mondrian.rolap.RolapConnection.execute
      (RolapConnection.java:198)
      at
      mondrian.web.servlet.MDXQueryServlet.processRequest
      (MDXQueryServlet.java:78)
      at mondrian.web.servlet.MDXQueryServlet.doGet
      (MDXQueryServlet.java:200)
      at javax.servlet.http.HttpServlet.service
      (HttpServlet.java:740)
      at javax.servlet.http.HttpServlet.service
      (HttpServlet.java:853)
      at
      org.apache.catalina.core.ApplicationFilterChain.internalDo
      Filter(ApplicationFilterChain.java:247)
      at
      org.apache.catalina.core.ApplicationFilterChain.doFilter
      (ApplicationFilterChain.java:193)
      at
      org.apache.catalina.core.StandardWrapperValve.invoke
      (StandardWrapperValve.java:256)
      at
      org.apache.catalina.core.StandardPipeline$StandardPipeli
      neValveContext.invokeNext(StandardPipeline.java:643)
      at org.apache.catalina.core.StandardPipeline.invoke
      (StandardPipeline.java:480)
      at org.apache.catalina.core.ContainerBase.invoke
      (ContainerBase.java:995)
      at
      org.apache.catalina.core.StandardContextValve.invoke
      (StandardContextValve.java:191)
      at
      org.apache.catalina.core.StandardPipeline$StandardPipeli
      neValveContext.invokeNext(StandardPipeline.java:643)
      at org.apache.catalina.core.StandardPipeline.invoke
      (StandardPipeline.java:480)
      at org.apache.catalina.core.ContainerBase.invoke
      (ContainerBase.java:995)
      at org.apache.catalina.core.StandardContext.invoke
      (StandardContext.java:2415)
      at org.apache.catalina.core.StandardHostValve.invoke
      (StandardHostValve.java:180)
      at
      org.apache.catalina.core.StandardPipeline$StandardPipeli
      neValveContext.invokeNext(StandardPipeline.java:643)
      at
      org.apache.catalina.valves.ErrorDispatcherValve.invoke
      (ErrorDispatcherValve.java:171)
      at
      org.apache.catalina.core.StandardPipeline$StandardPipeli
      neValveContext.invokeNext(StandardPipeline.java:641)
      at org.apache.catalina.valves.ErrorReportValve.invoke
      (ErrorReportValve.java:172)
      at
      org.apache.catalina.core.StandardPipeline$StandardPipeli
      neValveContext.invokeNext(StandardPipeline.java:641)
      at org.apache.catalina.core.StandardPipeline.invoke
      (StandardPipeline.java:480)
      at org.apache.catalina.core.ContainerBase.invoke
      (ContainerBase.java:995)
      at org.apache.catalina.core.StandardEngineValve.invoke
      (StandardEngineValve.java:174)
      at
      org.apache.catalina.core.StandardPipeline$StandardPipeli
      neValveContext.invokeNext(StandardPipeline.java:643)
      at org.apache.catalina.core.StandardPipeline.invoke
      (StandardPipeline.java:480)
      at org.apache.catalina.core.ContainerBase.invoke
      (ContainerBase.java:995)
      at org.apache.coyote.tomcat4.CoyoteAdapter.service
      (CoyoteAdapter.java:223)
      at org.apache.coyote.http11.Http11Processor.process
      (Http11Processor.java:594)
      at
      org.apache.coyote.http11.Http11Protocol$Http11Connec
      tionHandler.processConnection(Http11Protocol.java:392)
      at org.apache.tomcat.util.net.TcpWorkerThread.runIt
      (PoolTcpEndpoint.java:565)
      at
      org.apache.tomcat.util.threads.ThreadPool$ControlRunna
      ble.run(ThreadPool.java:619)
      at java.lang.Thread.run(Thread.java:536)
      java.lang.ClassCastException
      at mondrian.olap.fun.FunUtil.getMemberArg
      (FunUtil.java:163)
      at mondrian.olap.fun.TupleFunDef.evaluate
      (TupleFunDef.java:61)
      at mondrian.rolap.RolapEvaluator.xx
      (RolapEvaluator.java:129)
      at mondrian.olap.FunCall.evaluate(FunCall.java:247)
      at mondrian.olap.fun.SetFunDef.evaluate
      (SetFunDef.java:56)
      at mondrian.rolap.RolapEvaluator.xx
      (RolapEvaluator.java:129)
      at mondrian.olap.FunCall.evaluate(FunCall.java:247)
      at mondrian.rolap.RolapResult.executeAxis
      (RolapResult.java:150)
      at mondrian.rolap.RolapResult.<init>(RolapResult.java:70)
      at mondrian.rolap.RolapConnection.execute
      (RolapConnection.java:198)
      at
      mondrian.web.servlet.MDXQueryServlet.processRequest
      (MDXQueryServlet.java:78)
      at mondrian.web.servlet.MDXQueryServlet.doGet
      (MDXQueryServlet.java:200)
      at javax.servlet.http.HttpServlet.service
      (HttpServlet.java:740)
      at javax.servlet.http.HttpServlet.service
      (HttpServlet.java:853)
      at
      org.apache.catalina.core.ApplicationFilterChain.internalDo
      Filter(ApplicationFilterChain.java:247)
      at
      org.apache.catalina.core.ApplicationFilterChain.doFilter
      (ApplicationFilterChain.java:193)
      at
      org.apache.catalina.core.StandardWrapperValve.invoke
      (StandardWrapperValve.java:256)
      at
      org.apache.catalina.core.StandardPipeline$StandardPipeli
      neValveContext.invokeNext(StandardPipeline.java:643)
      at org.apache.catalina.core.StandardPipeline.invoke
      (StandardPipeline.java:480)
      at org.apache.catalina.core.ContainerBase.invoke
      (ContainerBase.java:995)
      at
      org.apache.catalina.core.StandardContextValve.invoke
      (StandardContextValve.java:191)
      at
      org.apache.catalina.core.StandardPipeline$StandardPipeli
      neValveContext.invokeNext(StandardPipeline.java:643)
      at org.apache.catalina.core.StandardPipeline.invoke
      (StandardPipeline.java:480)
      at org.apache.catalina.core.ContainerBase.invoke
      (ContainerBase.java:995)
      at org.apache.catalina.core.StandardContext.invoke
      (StandardContext.java:2415)
      at org.apache.catalina.core.StandardHostValve.invoke
      (StandardHostValve.java:180)
      at
      org.apache.catalina.core.StandardPipeline$StandardPipeli
      neValveContext.invokeNext(StandardPipeline.java:643)
      at
      org.apache.catalina.valves.ErrorDispatcherValve.invoke
      (ErrorDispatcherValve.java:171)
      at
      org.apache.catalina.core.StandardPipeline$StandardPipeli
      neValveContext.invokeNext(StandardPipeline.java:641)
      at org.apache.catalina.valves.ErrorReportValve.invoke
      (ErrorReportValve.java:172)
      at
      org.apache.catalina.core.StandardPipeline$StandardPipeli
      neValveContext.invokeNext(StandardPipeline.java:641)
      at org.apache.catalina.core.StandardPipeline.invoke
      (StandardPipeline.java:480)
      at org.apache.catalina.core.ContainerBase.invoke
      (ContainerBase.java:995)
      at org.apache.catalina.core.StandardEngineValve.invoke
      (StandardEngineValve.java:174)
      at
      org.apache.catalina.core.StandardPipeline$StandardPipeli
      neValveContext.invokeNext(StandardPipeline.java:643)
      at org.apache.catalina.core.StandardPipeline.invoke
      (StandardPipeline.java:480)
      at org.apache.catalina.core.ContainerBase.invoke
      (ContainerBase.java:995)
      at org.apache.coyote.tomcat4.CoyoteAdapter.service
      (CoyoteAdapter.java:223)
      at org.apache.coyote.http11.Http11Processor.process
      (Http11Processor.java:594)
      at
      org.apache.coyote.http11.Http11Protocol$Http11Connec
      tionHandler.processConnection(Http11Protocol.java:392)
      at org.apache.tomcat.util.net.TcpWorkerThread.runIt
      (PoolTcpEndpoint.java:565)
      at
      org.apache.tomcat.util.threads.ThreadPool$ControlRunna
      ble.run(ThreadPool.java:619)
      at java.lang.Thread.run(Thread.java:536)

      The problem seems to be with the implicit conversion of
      a dimension [Customers] to a member
      [Customers].DefaultMember. The workaround is to write

      ...
      where ([Time].[1997],[Customers].DefaultMember)

        Activity

        Mondrian Importer User added a comment -
        {jhyde}, 08/18/2003: status_id, 1 | {jhyde}

        , 08/18/2003: resolution_id, 100 |

        {jhyde}, 08/18/2003: assigned_to, 312935 | {jhyde}

        , 08/18/2003: close_date, 0

        Mondrian Importer User added a comment -
        {jhyde}

        , 08/18/2003: Logged In: YES
        user_id=312935

        Confirmed fixed, and added testcase.


          People

          • Assignee:
            ebengtso
            Reporter:
            Julian Hyde
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: