Pentaho Analysis - Mondrian
  1. Pentaho Analysis - Mondrian
  2. MONDRIAN-306

Parser should not require braces around range op in WITH SET

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Severe Severe
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.

      Description

      The MDX containing named set definition as member range fails in Mondrian 2.3.2.8944 (while succedes in MSAS 2000). Workaround: add curly braces over range statement.

      Example:


      with
       set [Set1] as '[Product].[Drink]:[Product].[Food]'
      select
       [Set1] on columns,
       {[Measures].defaultMember} on rows
      from Sales



      Result:
       

      mondrian.olap.MondrianException: Mondrian Error:Syntax error in MDX expression '[Product].[Drink]:[Product].[Food]'

            at mondrian.resource.MondrianResource$_Def0.ex(MondrianResource.java:755)

            at mondrian.olap.Parser.parseExpression(Parser.java:796)

            at mondrian.olap.Parser.recursivelyParseExp(Parser.java:730)

            at mondrian.olap.CUP$Parser$actions.CUP$Parser$do_action(Parser.java:1359)

            at mondrian.olap.Parser.do_action(Parser.java:685)

            at java_cup.runtime.lr_parser.parse(lr_parser.java:569)

            at mondrian.olap.Parser.parseInternal(Parser.java:755)

            at mondrian.olap.ConnectionBase.parseQuery(ConnectionBase.java:74)

            at mondrian.olap.ConnectionBase.parseQuery(ConnectionBase.java:59)

            at mondrian.web.servlet.MDXQueryServlet.processRequest(MDXQueryServlet.java:85)

            at mondrian.web.servlet.MDXQueryServlet.doGet(MDXQueryServlet.java:228)

            at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)

            at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

            at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)

            at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)

            at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)

            at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)

            at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)

            at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)

            at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)

            at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)

            at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)

            at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:744)

            at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)

            at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)

            at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)

            at java.lang.Thread.run(Thread.java:595)

      Caused by: mondrian.olap.MondrianException: Mondrian Error:Syntax error at line 1, column 19, token ':'

            at mondrian.resource.MondrianResource$_Def4.ex(MondrianResource.java:825)

            at mondrian.olap.Parser.syntax_error(Parser.java:886)

            at java_cup.runtime.lr_parser.parse(lr_parser.java:595)

            at mondrian.olap.Parser.parseExpression(Parser.java:791)

            ... 25 more

      mondrian.olap.MondrianException: Mondrian Error:Syntax error at line 1, column 19, token ':'

            at mondrian.resource.MondrianResource$_Def4.ex(MondrianResource.java:825)

            at mondrian.olap.Parser.syntax_error(Parser.java:886)

            at java_cup.runtime.lr_parser.parse(lr_parser.java:595)

            at mondrian.olap.Parser.parseExpression(Parser.java:791)

            at mondrian.olap.Parser.recursivelyParseExp(Parser.java:730)

            at mondrian.olap.CUP$Parser$actions.CUP$Parser$do_action(Parser.java:1359)

            at mondrian.olap.Parser.do_action(Parser.java:685)

            at java_cup.runtime.lr_parser.parse(lr_parser.java:569)

            at mondrian.olap.Parser.parseInternal(Parser.java:755)

            at mondrian.olap.ConnectionBase.parseQuery(ConnectionBase.java:74)

            at mondrian.olap.ConnectionBase.parseQuery(ConnectionBase.java:59)

            at mondrian.web.servlet.MDXQueryServlet.processRequest(MDXQueryServlet.java:85)

            at mondrian.web.servlet.MDXQueryServlet.doGet(MDXQueryServlet.java:228)

            at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)

            at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

            at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)

            at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)

            at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)

            at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)

            at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)

            at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)

            at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)

            at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)

            at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)

            at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:744)

            at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)

            at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)

            at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)

            at java.lang.Thread.run(Thread.java:595)

        Activity

        Mondrian Importer User added a comment -
        {anikitin}, 07/10/2007: IP, Artifact Created: 217.119.25.147 |
        {jhyde}, 07/10/2007: IP, Comment Added: 64.81.57.79 |
        {jhyde}, 07/10/2007: status_id, 1 |
        {jhyde}, 07/10/2007: resolution_id, 100 |
        {jhyde}, 07/10/2007: assigned_to, 100 |
        {jhyde}, 07/10/2007: summary, MDX Parser bug: named set + range |
        {jhyde}, 07/10/2007: close_date, 0
        Mondrian Importer User added a comment -
        {jhyde}, 07/10/2007: Logged In: YES
        user_id=312935
        Originator: NO

        Fixed in change 1751352; will be in mondrian-2.4.

          People

          • Assignee:
            Julian Hyde
            Reporter:
            anikitin
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: