Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Severe Severe
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.

      Description

      I've attached a schema that has a fully denormalized fact table (e.g. where all dimension members are collapsed into the fact table. This happens to be one of our requirements.) But having an aggregate table on top of the fact table will cause "unknown usage" warnings. This looks like an issue with in Recognizer.checkLevels() where the hierarchyUsage has no foreign key, thus will not match any of the notSeenForeignKeys. This ends up preventing the code from trying to match the levels to the aggtable columns. This is serious because I think this prevents the aggtable from being used at all.

      2007-05-18 11:13:48,784 [http-8080-Processor25] WARN mondrian.rolap.aggmatcher.AggTableManager - Recognizer.checkUnusedColumns: Candidate aggregate table 'agg_1_facts' for fact table 'facts' has a column 'month' with unknown usage.
      2007-05-18 11:13:48,784 [http-8080-Processor25] WARN mondrian.rolap.aggmatcher.AggTableManager - Recognizer.checkUnusedColumns: Candidate aggregate table 'agg_1_facts' for fact table 'facts' has a column 'office_country' with unknown usage.
      2007-05-18 11:13:48,784 [http-8080-Processor25] WARN mondrian.rolap.aggmatcher.AggTableManager - Recognizer.checkUnusedColumns: Candidate aggregate table 'agg_1_facts' for fact table 'facts' has a column 'day' with unknown usage.
      2007-05-18 11:13:48,784 [http-8080-Processor25] WARN mondrian.rolap.aggmatcher.AggTableManager - Recognizer.checkUnusedColumns: Candidate aggregate table 'agg_1_facts' for fact table 'facts' has a column 'office_name' with unknown usage.
      2007-05-18 11:13:48,784 [http-8080-Processor25] WARN mondrian.rolap.aggmatcher.AggTableManager - Recognizer.checkUnusedColumns: Candidate aggregate table 'agg_1_facts' for fact table 'facts' has a column 'office_city' with unknown usage.
      2007-05-18 11:13:48,784 [http-8080-Processor25] WARN mondrian.rolap.aggmatcher.AggTableManager - Recognizer.checkUnusedColumns: Candidate aggregate table 'agg_1_facts' for fact table 'facts' has a column 'source_name' with unknown usage.
      2007-05-18 11:13:48,784 [http-8080-Processor25] WARN mondrian.rolap.aggmatcher.AggTableManager - Recognizer.checkUnusedColumns: Candidate aggregate table 'agg_1_facts' for fact table 'facts' has a column 'office_state' with unknown usage.
      2007-05-18 11:13:48,784 [http-8080-Processor25] WARN mondrian.rolap.aggmatcher.AggTableManager - Recognizer.checkUnusedColumns: Candidate aggregate table 'agg_1_facts' for fact table 'facts' has a column 'symbol' with unknown usage.
      2007-05-18 11:13:48,784 [http-8080-Processor25] WARN mondrian.rolap.aggmatcher.AggTableManager - Recognizer.checkUnusedColumns: Candidate aggregate table 'agg_1_facts' for fact table 'facts' has a column 'source_type' with unknown usage.
      2007-05-18 11:13:48,784 [http-8080-Processor25] WARN mondrian.rolap.aggmatcher.AggTableManager - Recognizer.checkUnusedColumns: Candidate aggregate table 'agg_1_facts' for fact table 'facts' has a column 'year' with unknown usage.

        Activity

        Mondrian Importer User added a comment -
        {alanli}, 05/18/2007: IP, Artifact Created: 204.11.227.33 | {alanli}

        , 05/18/2007: File Added, 229748: fx.xml |

        {jhyde}, 05/22/2007: IP, Comment Added: 64.81.57.79 | {jhyde}

        , 05/22/2007: status_id, 1 |

        {jhyde}, 05/22/2007: resolution_id, 100 | {jhyde}

        , 05/22/2007: close_date, 0 |

        {jhyde}, 07/16/2007: IP, Comment Added: 66.92.12.96 | {jhyde}

        , 07/16/2007: resolution_id, 6

        Mondrian Importer User added a comment -
        {jhyde}

        , 05/22/2007: Logged In: YES
        user_id=312935
        Originator: NO

        I have checked in a testcase against the FoodMart schema which should reproduce this bug. See SchemaTest.testUnknownUsages().

        But the code produces the same results with or without the patch, which was to change

        boolean b =
        inNotSeenForeignKeys(
        foreignKey,
        notSeenForeignKeys);

        to

        boolean b = foreignKey == null ||
        inNotSeenForeignKeys(
        foreignKey,
        notSeenForeignKeys);

        in Recognizer.java, and I don't really understand how the fix is supposed to work.

        So I have not applied the fix. I am marking this bug 'Works for me'. Please try to modify the testcase I created to demonstrate the problem. If you can do that, please reopen the bug, and I will apply the fix.

        Julian

        Mondrian Importer User added a comment -
        {jhyde}

        , 07/16/2007: Logged In: YES
        user_id=312935
        Originator: NO

        Alan Li provided a testcase which reproduces this problem; checked in testcase and fix in change 9603. Will be in mondrian-2.4.


          People

          • Assignee:
            Unassigned User
            Reporter:
            alanli
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: