Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Severe Severe
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.

      Description

      I'm seeing a ClassCastException in
      AggQuerySpec.addMeasure(int, SqlQuery) line: 99 when it
      tries to cast getMeasureAsColumn(i) into an
      AggStar.FactTable.Measure. The issue is that the
      column being returned is actually an
      AggStar.Table.Level. And this should be ok according
      to the comment in AggQuerySpec.generateSql(SqlQuery)
      line: 150, which states that "This can also add
      non-shared local dimension columns, which are not
      measures."

      Thread [http-8080-Processor24] (Suspended (exception
      ClassCastException))
       AggQuerySpec.addMeasure(int, SqlQuery) line: 99
       AggQuerySpec.generateSql(SqlQuery) line: 150
       AggQuerySpec.generateSqlQuery() line: 94
       AggregationManager.generateSql(Segment[], BitKey,
      BitKey) line: 183
       Segment.load(Segment[], BitKey, BitKey, Collection,
      Aggregation$Axis[]) line: 251
       Aggregation.load(RolapStar$Column[],
      RolapStar$Measure[], ColumnConstraint[][], Collection)
      line: 138
       AggregationManager.loadAggregation(RolapStar$Measure[],
      RolapStar$Column[], BitKey, ColumnConstraint[][],
      Collection) line: 82
       FastBatchingCellReader$Batch.loadAggregation() line: 359
       FastBatchingCellReader.loadAggregations(Query) line: 203
       RolapResult.<init>(Query, boolean) line: 105
       RolapConnection.execute(Query) line: 363
       MondrianModel.getResult() line: 186
       CachingOlapModel(OlapModelDecorator).getResult() line: 54
       CachingOlapModel.getResult() line: 48
       OlapModelProxy(OlapModelDecorator).getResult() line: 54
       NativeMethodAccessorImpl.invoke0(Method, Object,
      Object[]) line: not available [native method]
       NativeMethodAccessorImpl.invoke(Object, Object[]) line: 39
       DelegatingMethodAccessorImpl.invoke(Object, Object[])
      line: 25
       Method.invoke(Object, Object...) line: 585
       PropertySuffix(ArraySuffix).evaluate(Object, Object,
      VariableResolver, Map, String, Logger) line: 278
       ComplexValue.evaluate(Object, VariableResolver, Map,
      String, Logger) line: 107
       ELEvaluator.evaluate(String, Object, Class, Map,
      String, Logger) line: 204
       ELEvaluator.evaluate(String, Object, Class, Map,
      String) line: 163
       Evaluator.evaluate(String, String, Class, Tag,
      PageContext, Map, String) line: 101
       Evaluator.evaluate(String, String, Class, Tag,
      PageContext) line: 129
       ExpressionEvaluatorManager.evaluate(String, String,
      Class, Tag, PageContext) line: 75
       IfTag.condition() line: 58
       IfTag(ConditionalTagSupport).doStartTag() line: 122
       testpage.jsp line: 94
       testpage.jsp line: not available
       testpage_jsp(HttpJspBase).service(HttpServletRequest,
      HttpServletResponse) line: 97
       testpage_jsp(HttpServlet).service(ServletRequest,
      ServletResponse) line: 802
       JspServletWrapper.service(HttpServletRequest,
      HttpServletResponse, boolean) line: 332
       JspServlet.serviceJspFile(HttpServletRequest,
      HttpServletResponse, String, Throwable, boolean) line: 314
       JspServlet.service(HttpServletRequest,
      HttpServletResponse) line: 264
       JspServlet(HttpServlet).service(ServletRequest,
      ServletResponse) line: 802
       ApplicationFilterChain.internalDoFilter(ServletRequest,
      ServletResponse) line: 252
       ApplicationFilterChain.doFilter(ServletRequest,
      ServletResponse) line: 173
       RequestFilter$MyHandler.normalRequest() line: 139
       RequestSynchronizer.handleRequest(RequestSynchronizer$Handler)
      line: 127
       RequestFilter.doFilter(ServletRequest,
      ServletResponse, FilterChain) line: 263
       ApplicationFilterChain.internalDoFilter(ServletRequest,
      ServletResponse) line: 202
       ApplicationFilterChain.doFilter(ServletRequest,
      ServletResponse) line: 173
       StandardWrapperValve.invoke(Request, Response) line: 213
       StandardContextValve.invoke(Request, Response) line: 178
       StandardHostValve.invoke(Request, Response) line: 126
       ErrorReportValve.invoke(Request, Response) line: 105
       StandardEngineValve.invoke(Request, Response) line: 107
       CoyoteAdapter.service(Request, Response) line: 148
       Http11Processor.process(InputStream, OutputStream)
      line: 869
       Http11Protocol$JmxHttp11ConnectionHandler(Http11BaseProtocol$Http11ConnectionHandler).processConnection(TcpConnection,
      Object[]) line: 664
       PoolTcpEndpoint.processSocket(Socket, TcpConnection,
      Object[]) line: 527
       LeaderFollowerWorkerThread.runIt(Object[]) line: 80
       ThreadPool$ControlRunnable.run() line: 684
       ThreadWithAttributes(Thread).run() line: 595

        Activity

        Mondrian Importer User added a comment -
        {jhyde}, 08/10/2007: IP, Comment Added: 66.92.12.96 |
        {jhyde}, 08/10/2007: status_id, 1 |
        {jhyde}, 08/10/2007: resolution_id, 100 |
        {jhyde}, 08/10/2007: assigned_to, 100 |
        {jhyde}, 08/10/2007: close_date, 0
        Mondrian Importer User added a comment -
        {defenestrate}, 10/20/2006: Logged In: YES
        user_id=1618949

        I found that this problem occurs because I have two
        different measures in two different cubes with the same
        measure name in the same schema file. Each cube has its own
        distinct aggregation table that contains the aggregate for
        each respective measure. Apparently, Mondrian doesn't like
        this because once I renamed one of the measures everything
        was kosher again.
        Mondrian Importer User added a comment -
        {jhyde}, 08/10/2007: Logged In: YES
        user_id=312935
        Originator: NO

        Fixed in change 9740. Will be in mondrian-2.4.1.

        The testcase didn't show up precisely this issue, but something related, which was fixed by qualifying measures in a RolapStar with cube name.

        defenestrate, please confirm that this bug is fixed. If not, please re-open this bug.

          People

          • Assignee:
            Julian Hyde
            Reporter:
            defenestrate
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: