Pentaho Analysis - Mondrian
  1. Pentaho Analysis - Mondrian
  2. MONDRIAN-168

NullPointerException in RolapEvaluator.setContext(....)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Severe Severe
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      MDX-queries containing the measure "Employee Salary"
      from Cube "HR" of the Foodmart-Schema throw a
      NullPointerException.

      Example-Queries:

      select

           {[Employee Salary]} on columns,
           {[Employees]} on rows

      from [HR]


      or

      select

           {[Position]} on columns,
           {[Employee Salary]} on rows

      from [HR]


      important part of the Stacktrace:

      Caused by: mondrian.olap.MondrianException: Mondrian
      Error:Internal error: Error while executing query
      [select {[Position].CurrentMember} ON COLUMNS,
        {[Measures].[Employee Salary]} ON ROWS
      from [HR]
      ]
       at
      mondrian.resource.MondrianResource$_Def0.ex(MondrianResource.java:846)
       at mondrian.olap.Util.newInternal(Util.java:983)
       at mondrian.olap.Util.newError(Util.java:1003)
       at
      mondrian.rolap.RolapConnection.execute(RolapConnection.java:352)
       at
      com.tonbeller.jpivot.mondrian.MondrianModel.getResult(MondrianModel.java:191)
       ... 34 more
      Caused by: java.lang.NullPointerException
       at
      mondrian.rolap.RolapEvaluator.setContext(RolapEvaluator.java:215)
       at
      mondrian.olap.fun.FunTableImpl$MemberListScalarExp.evaluate(FunTableImpl.java:525)
       at mondrian.olap.ExpBase.evaluateScalar(ExpBase.java:100)
       at
      mondrian.rolap.RolapEvaluator.evaluateCurrent(RolapEvaluator.java:256)
       at
      mondrian.rolap.RolapResult.executeStripe(RolapResult.java:377)
       at
      mondrian.rolap.RolapResult.executeStripe(RolapResult.java:405)
       at
      mondrian.rolap.RolapResult.executeStripe(RolapResult.java:405)
       at
      mondrian.rolap.RolapResult.executeBody(RolapResult.java:264)
       at mondrian.rolap.RolapResult.<init>(RolapResult.java:188)
       at
      mondrian.rolap.RolapConnection.execute(RolapConnection.java:329)
       ... 35 more

        Activity

        Mondrian Importer User added a comment -
        {jhyde}, 03/28/2006: status_id, 1 |
        {jhyde}, 03/28/2006: resolution_id, 100 |
        {jhyde}, 03/28/2006: close_date, 0
        Mondrian Importer User added a comment -
        {jhyde}, 03/28/2006: Logged In: YES
        user_id=312935

        Cannot reproduce as of change 6006. Maybe a duplicate of
        1418689?

          People

          • Assignee:
            Unassigned User
            Reporter:
            rehdie_easyplex
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: