Pentaho Analysis - Mondrian
  1. Pentaho Analysis - Mondrian
  2. MONDRIAN-137

error if calc member in schema file contains single quotes

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Severe Severe
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.

      Description

      Mondrian gives an error if the definition of a
      calculated member in a schema.xml file contains
      single-quotes.

      The cause is as follows. When loading a schema,
      Mondrian generates an internal MDX query containing all
      of the calculated members and named sets in that
      schema, in order to validate them. The problem is that
      it does not correctly escape the text of those formulas.

      For a use case, see the forum thread "Problem with
      assigning color to cells",
      https://sourceforge.net/forum/message.php?msg_id=3531339

        Activity

        Mondrian Importer User added a comment -
        {jhyde}, 03/28/2006: status_id, 1 | {jhyde}

        , 03/28/2006: resolution_id, 100 |

        {jhyde}

        , 03/28/2006: close_date, 0

        Mondrian Importer User added a comment -
        {jhyde}

        , 03/28/2006: Logged In: YES
        user_id=312935

        Fixed in change 6001, release mondrian-2.1.


          People

          • Assignee:
            Unassigned User
            Reporter:
            Julian Hyde
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: