Pentaho Analysis - Mondrian
  1. Pentaho Analysis - Mondrian
  2. MONDRIAN-1030

Members disappearing with RoleUnion and complex MDX query

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.3.0 GA (4.1.0 GA Suite Release)
    • Component/s: None
    • Labels:
      None
    • Customer Case:
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.
    • QA Validation Status:
      Validated by QA

      Description

      This case relates to ESR-1464.

      • Deploy the schema attached to this case.
      • Connect through XMLA using Rex or some other XMLA tool.
      • Run the following query:

      SELECT
      NON EMPTY

      { [Measures].[Quantity] }

      ON COLUMNS,

      NON EMPTY {

      Crossjoin(

      { [Markets].[APAC] , [Markets].[EMEA] }

      ,

      {[Product].[Line].Members}

      )
      } ON ROWS

      FROM [SteelWheelsSalesProf]

      • This returns the expected results, namely numbers for both APAC and EMEA.
      • Run this next query:

      With
      Set [*NATIVE_CJ_SET] as 'NonEmptyCrossJoin([*BASE_MEMBERS_Markets],[*BASE_MEMBERS_Product])'
      Set [*SORTED_ROW_AXIS] as 'Order([*CJ_ROW_AXIS],[Markets].CurrentMember.OrderKey,BASC,[Product].CurrentMember.OrderKey,BASC)'
      Set [*BASE_MEMBERS_Markets] as '[Markets].[Territory].Members'
      Set [*BASE_MEMBERS_Product] as '[Product].[Line].Members'
      Set [*BASE_MEMBERS_Measures] as '

      {[Measures].[*FORMATTED_MEASURE_0]}

      '
      Set [*CJ_ROW_AXIS] as 'Generate([*NATIVE_CJ_SET],

      {([Markets].currentMember,[Product].currentMember)}

      )'
      Set [*CJ_COL_AXIS] as '[*NATIVE_CJ_SET]'
      Member [Measures].[*FORMATTED_MEASURE_0] as '[Measures].[Quantity]', FORMAT_STRING = '#,###', SOLVE_ORDER=400
      Select
      [*BASE_MEMBERS_Measures] on columns,
      Non Empty [*SORTED_ROW_AXIS] on rows
      From [SteelWheelsSalesProf]

      • This query returns only APAC.

      The second query was generated by Analyzer when dragging the fields Territory, Line and Quantity. They should return the same results, but they don't.

      1. first_query.png
        119 kB
      2. screenshot.10.png
        295 kB
      3. Screenshot.png
        309 kB
      4. second_query_only_APAC.png
        133 kB

        Activity

        Luc Boudreau added a comment -

        Repro steps:

        • This one is a bit too hard to reproduce independently. Julian has created a unit test that creates the schema, runs the query and validates the results. If it passes, this bug is fixed. It can be found here:

        http://ci.pentaho.com/view/Analysis/job/mondrian/lastCompletedBuild/testReport/mondrian.test/AccessControlTest/testMondrian1030/

        Brandon Bruce added a comment - - edited

        It seems that multiple people have reported this as failing in Ubuntu. Please create a Ubuntu VM and retest so we can be sure this is fixed.

        Luc Boudreau added a comment -

        I've tested it in Ubuntu 11.10 with Mondrian build #1348 on BI Server CE 4.5.0-RC1 with Hypersonic. It works as expected. See the attached screenshot.

        I'd like to identify what step you missed. can you give me a detailed step-by-step account of what you have done?

        Brandon Bruce added a comment -

        Carlos,
        Please provide your reproduction path so we can determine if this is still an issue.

        Brandon Bruce added a comment -

        Since Carlos cannot reproduce, I am closing this issue.


          People

          • Assignee:
            Brandon Bruce
            Reporter:
            Luc Boudreau
          • Votes:
            2 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: