Uploaded image for project: 'Pentaho BA Platform'
  1. Pentaho BA Platform
  2. BISERVER-12199

IMondrianCatalogService.loadCatalogs call on 5.2 EE fails because mondrian 4 doesn't have access to org.pentaho.platform.web.servlet.PentahoDataSourceResolver

    Details

    • Type: Bug
    • Status: Closed
    • Severity: Medium
    • Resolution: Fixed
    • Affects Version/s: 5.2.0 GA, 5.3.0 GA, 5.4.0 GA
    • Fix Version/s: 6.0.0 GA
    • Component/s: None
    • Labels:
      None
    • Story Points:
      0
    • Notice:
      When an issue is open, the "Fix Version/s" field conveys a target, not necessarily a commitment. When an issue is closed, the "Fix Version/s" field conveys the version that the issue was fixed in.

      Description

      Running 5.2 EE Mondrian 4 is in OSGI and it doesn't import org.pentaho.platform.web.servlet.PentahoDataSourceResolver

      this means plugins etc that use it, fail because mondrian tries to connect and it gives a ClassNotFoundException

      If I add it to the mondrian jar is starts working fine.

      1. MANIFEST.MF
        6 kB
        Tom Barber
      2. saiku_log.txt
        16 kB
        Carlos Lopez

        Issue Links

          Activity

          bugg_tb Tom Barber added a comment -

          I don't have a Pentaho EE build here, and rumour has it it might be fixed in 5.3, although i'd be surprised because i've had other people telling me its not, but Pedro has been talking with bizcubed about it so I dunno, I've asked brandon to check in 5.3 if he gets time.

          We call the BI server for data sources from the plugin and the BI server then goes off looking for Mondrian cubes defined in the Data Sources GUI, the failure doesn't matter about Mondrian 3 or 4 connections(this fails on a stock EE server, so its 3 as well) because the platform tries to bootstrap any mondrian server it can find, and so it finds the Mondrian server in the OSGI Libs directory and tries to spin it up, but, at that point the OSGI libs need an import for org.pentaho.platform.web.servlet.PentahoDataSourceResolver which is missing, and so it fails hard. As soon as you add that line to the Manifest file, the platform can talk to the Mondrian 4 jar and everything starts working(even if you just have mondrian 3 data sources).

          Tom

          brandonjusa Brandon Jackson added a comment - - edited

          This is still an issue in Pentaho BA Server 5.4.0.0-128-EE. Please look at it.
          Same fix. Simply adding org.pentaho.platform.web.servlet.PentahoDataSourceResolver to the import section of MANIFEST.MF fixes the issue.

          clopez Carlos Lopez added a comment - - edited

          Luc:
          Here are the reproduction steps:

          • Install clean 5.4 BA Vanilla
          • Install Marketplace
          • Install Saiku Analytics plugin
          • Click on Create New Saiku Analytics
          • Click on Create New Query notice none of the data sources are shown
          bugg_tb Tom Barber added a comment -

          I don't know what happened in the end after Pedro said it was our fault. As there has been action here, I assume a fix has gone into the BI server or Mondrian build somewhere?

          lboudreau Luc Boudreau added a comment - - edited

          Hi Tom.

          This is the change.

          https://github.com/pentaho/mondrian/pull/536/files

          The DS resolver should work through this Jar now.


            People

            • Assignee:
              Unassigned
              Reporter:
              bugg_tb Tom Barber
            • Votes:
              5 Vote for this issue
              Watchers:
              13 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: